linux/centos6.5安装glibc-2.14

2018-12-01 18:36:00
admin
原创
2081

今天在部署喧喧IM即时通讯软件服务端XXd时,提示找不到glibc2.14版本文件,所以需要安装glibc。操作非常简单:

到http://ftp.gnu.org/gnu/glibc/下载glibc-2.14.tar.gz

tar zxvf glibc-2.14.tar.gz
cd glibc-2.14
mkdir build
cd build
../configure --prefix=/usr/local/glibc-2.14
make -j4
make install
rm -rf /lib64/libc.so.6
ln -s /usr/local/glibc-2.14/lib/libc-2.14.so /lib64/libc.so.6
LD_PRELOAD=/usr/local/glibc-2.14/lib/libc-2.14.so  ln -s /usr/local/glibc-2.14/lib/libc-2.14.so /lib64/libc.so.6

安装成功。

版权声明

版权声明:本站原创文章,转载请注明作者和出处。

本站点采用  知识共享署名-非商业性使用-禁止演绎 4.0 国际许可协议    

发表评论
评论通过审核后显示。